Quantcast

2nd Gen front brakes

Yamaha Star V-Max VMAX Motorcycle Discussion Forum

Help Support VMAX Forum:

Joined
Nov 13, 2020
Messages
9
Reaction score
2
Just got a 2009 2nd gen, and the front shakes when braking above 60mph. I don't think it is the rotors because under 60mph it is smooth regardless of pressure applied. Was wondering if it is typical of the ABS system. I've owned 2 other bikes with abs and they didn't do this.
 

Jerry Klay

Well-Known Member
Joined
Jun 2, 2019
Messages
173
Reaction score
106
+1 on the rotor buttons. I've had my 09 front brake pulse usually a hard grab at even 30-40 mph seems to correct it
 
Joined
Nov 13, 2020
Messages
9
Reaction score
2
Cleaned and lubed all buttons, cleaned and lubed slide pins for the pads. Still only vibrates above 60.
 

Jerry Klay

Well-Known Member
Joined
Jun 2, 2019
Messages
173
Reaction score
106
I had a wobble at 50-55. Had a hell of a time finding it. Turned out to be the tire. Don't know if it was bad from the beginning it wore bad from a bad balance.

Had the front off the ground. Calipers off and had a block close to the tire and gave it a spin. It was grossly obvious it was out of round by about 1/4".

Just a thought as something to check.
 
Joined
Nov 13, 2020
Messages
9
Reaction score
2
Was yours only vibrating while braking? Riding is smooth as anything just only the front brakes above 60mph, like 58mph smooth brakes, 60 plus it vibrates.
 

Jerry Klay

Well-Known Member
Joined
Jun 2, 2019
Messages
173
Reaction score
106
Hands off the bars would wobble. Touch the bars would stop. Felt pulsing when light breaking.
 

Latest posts

Top