450-Mile Ride Today + Possible Fuel Pump Issues

Discussion in 'General VMax Questions' started by Lotsokids, Oct 1, 2017.

Help Support VMAX Motorcycle Forum by donating:

  1. Dec 4, 2017 #21

    Lotsokids

    Lotsokids

    Lotsokids

    Well-Known Member

    Joined:
    Jul 17, 2009
    Messages:
    558
    Likes Received:
    0
    Location:
    Oklahoma City, OK
    I drained the tank and nearly no rust or dirt came out.

    And the Mr. Gasket fuel pump... I remember there was an issue with no return or something? Maybe someone can chime in and verify.
     
  2. Dec 5, 2017 #22

    D-Max2012

    D-Max2012

    D-Max2012

    Well-Known Member

    Joined:
    Oct 25, 2012
    Messages:
    1,184
    Likes Received:
    0
    Location:
    NJ
    Not only do I hear it click at idle, (I counted it,, about once every 2 seconds, really slow compared to bowls pressurizing at key start), but, because I have a clear glass filter,, I could see the pulse of the fuel going in.. As I rev it up, the pulse gets faster.
    Filter.jpg
     
  3. Jan 30, 2018 #23

    Lotsokids

    Lotsokids

    Lotsokids

    Well-Known Member

    Joined:
    Jul 17, 2009
    Messages:
    558
    Likes Received:
    0
    Location:
    Oklahoma City, OK
    FUEL PUMP

    I installed a BRAND NEW $200 OEM fuel pump today. Turned the bike on... no clicking. Not one. Turned the bike off and on again, and only 2 clicks. Started right up and ran well. I didn't hear any clicking at all.

    My old pump (original) would click practically non-stop with key on and while idling. I could even hear it clicking over the idle even with my very loud exhaust.

    So I am confident my fuel pump was failing. Glad to have faith in my bike now for longer trips!
     
  4. Sep 4, 2018 #24

    KrazyHorseArabians

    KrazyHorseArabians

    KrazyHorseArabians

    New Member

    Joined:
    Sep 4, 2018
    Messages:
    1
    Likes Received:
    0
    Location:
    Macon, Ga
    I am having the same issues new Chinese pump new fuel filter no cracks in the lines. Did you figure out anything else?
     

Share This Page

arrow_white