Gear indicator issue

Yamaha Star V-Max VMAX Motorcycle Discussion Forum

Help Support VMAX Forum:

Hydro33

New Member
Joined
Dec 12, 2021
Messages
1
Reaction score
0
Hello Maxers! I ride a 2018. 35k miles. Sometimes I get a gear indicator that goes blank, and scrolls between blank and the current gear. I looked at my wiring diagram in my service manual, and suspect the gear indicator switch is the culprit. Before I go digging with my lab scope, have any of you had gear indicator switch failure? Thanks! Brad.
 

one2dmax

Well-Known Member
Joined
Apr 6, 2006
Messages
16,254
Reaction score
1,032
Location
Derby Kansas
I think it's a pretty common issue. Sometimes I Think resolved by cleaning contacts and others by replacing the sending unit. I even keep one in stock just in case it's needed.
 

Marauder03

Well-Known Member
Joined
Jun 8, 2019
Messages
218
Reaction score
224
Location
Ohio
My 2012 does that sometimes as well but only when I’m in 2nd gear, just glad to know it’s kind of a common problem. Not that I want it but just that I now know.
 

Vmax06

Active Member
Joined
Jul 7, 2010
Messages
40
Reaction score
0
Location
Baker, MT
Mine did that too. I replaced the gear position sensor and it fixed it. I think I could have repaired it without buying a sensor though. This video is pretty decent at showing what happens and what the fix might be if you wanna try it before buying a new sensor. Obviously not a VMAX but the one our bikes looks very similar and works the same way. Either way it’s a pretty easy job. It probably took me longer just routing the new pigtail and connector in the correct oe routing.

 
Top