Gen II Headlight Bulb replacement

Discussion in 'Electrical' started by BamaMax, Jun 3, 2019.

Help Support VMAX Motorcycle Forum by donating:

  1. Jun 3, 2019 #1

    BamaMax

    BamaMax

    BamaMax

    Member

    Joined:
    Aug 8, 2011
    Messages:
    11
    Likes Received:
    0
    Location:
    Dothan, Al
    Anyone replaced the OEM bulb? I picked up an aftermarket bulb the other day it doesn't look like the factory bulb. It has (3) prongs like your plug should snap on it, but I am having problems...

    Anyone done this that can help a bro out?
     
  2. Jun 3, 2019 #2

    one2dmax

    one2dmax

    one2dmax

    Well-Known Member

    Joined:
    Apr 6, 2006
    Messages:
    14,903
    Likes Received:
    75
    Location:
    Derby Kansas
    The standard H4 bulbs should work? I do have high output versions of the bulb but not sure why you are having issues?
     
  3. Jun 3, 2019 #3

    BamaMax

    BamaMax

    BamaMax

    Member

    Joined:
    Aug 8, 2011
    Messages:
    11
    Likes Received:
    0
    Location:
    Dothan, Al
    Sean ~ I'll you why. Because I am a dumbass.
    It looks like the previous owner has switched to HID. To be honest, I was expecting a simple unplug and plug back in (I've never had HID lights before). These lights are hardwired in it looks like. Now my question becomes do I just need to replace the HID unit or "convert" it back to stock? I rarely ride at night.... If I do replace the HID, will any brand work? I'll post a few pics..
     
  4. Jun 3, 2019 #4

    BamaMax

    BamaMax

    BamaMax

    Member

    Joined:
    Aug 8, 2011
    Messages:
    11
    Likes Received:
    0
    Location:
    Dothan, Al
    Any opinions? I really don't know much about these lights...
    Thanks~!
     

    Attached Files:

  5. Jun 6, 2019 #5

    Jerry Klay

    Jerry Klay

    Jerry Klay

    New Member

    Joined:
    Jun 2, 2019
    Messages:
    2
    Likes Received:
    0
    The PO of my 2009 put in an after market HID as well. I have not had to replace the lamp yet. There should be some High Voltage drive electronics up stream from the lamp. I would suspect there is some information on that driver where to get a replacement lamp. Or maybe it is the drive electronics that are shot. My lamp is VERY bright and a blue'ish color temp. At PM it isn't worth a crap I can hardly see. The reflector is not designed for that lamp. However the guys I ride with during the day think it is great since I am VERY easy to spot.
     
  6. Jun 7, 2019 #6

    BamaMax

    BamaMax

    BamaMax

    Member

    Joined:
    Aug 8, 2011
    Messages:
    11
    Likes Received:
    0
    Location:
    Dothan, Al
    Hey Jerry ~ thanks for the response. I've taken my bike apart a little bit and have found that it is a Prestige HID ballast and bulb. I've got a call into them now. I would have rather just had the standard highlight bulb (I think) at this point in time... I'll post when I get it working..
    Thanks again.
     
  7. Jun 8, 2019 #7

    BamaMax

    BamaMax

    BamaMax

    Member

    Joined:
    Aug 8, 2011
    Messages:
    11
    Likes Received:
    0
    Location:
    Dothan, Al
    Struck out today... I found a Prestige Auto Lab and I thought it was it. Sent them pics and they said it's not theirs... Found a Prestige HID on Facebook but it said permanently closed. Guess I'm going to try and take it back to stock...
    I was hoping the factory 3-prong connector would still be there but it's missing. Going to bike shop in the morning to talk them..
     

Share This Page



arrow_white