ABS light

VMAX  Forum

Help Support VMAX Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

Maxman376

Well-Known Member
Joined
Oct 29, 2018
Messages
75
Reaction score
33
Location
DELTONA
I have a 2018 vmax with 18k on it. Lately the abs light will start flashing. I can turn off while going down road and reset. Light goes off and will stay out for 2 to 3 weeks then randomly come back on. Anybody had trouble with this problem.
 
From the service manual...

THE ABS WARNING LIGHT FLASHES
1. Check whether the T/C terminal (green/yellow) of the ABS test coupler is short-circuited to the
ground when the test coupler adapter is removed.
• If the T/C terminal is short-circuited to the ground, the wire harness is defective. Properly repair or
replace the wire harness.
ABS (ANTI-LOCK BRAKE SYSTEM)
8-85
• If the T/C terminal is not short-circuited to the ground, the internal circuit of the meter assembly 1 is
defective. Replace the meter assembly 1.
 
I have a 2018 vmax with 18k on it. Lately the abs light will start flashing. I can turn off while going down road and reset. Light goes off and will stay out for 2 to 3 weeks then randomly come back on. Anybody had trouble with this problem.

Do you have an aftermarket integrated tail light?
 
I get this when I take off and the rear wheel burns out, resulting in a large difference in rear/front wheel rotation. Restart the bike and it's gone. Not much different that when you are on a dyno and the rear wheel is turning, but the front isn't. The ABS light blinks the entire time.
 
A common issue with the aftermarket integrated tail lights is that they cause intermittent ABS faults. The fix is to wire a resistor in the circuit. I've done it both of my Gen 2's.

Not sure I have any documentation on the fix, I'd have to look when I get a chance.

It's another one of those things that was "lost" when the other forum went down.
 
I have a integrated taillight but I tried the resistor and didn't work. Still to this day only happens about every 2 to 3 week's.
 
A common issue with the aftermarket integrated tail lights is that they cause intermittent ABS faults. The fix is to wire a resistor in the circuit. I've done it both of my Gen 2's.

Not sure I have any documentation on the fix, I'd have to look when I get a chance.

It's another one of those things that was "lost" when the other forum went down.

interesting, my ABS light has started flashing after some hard braking a couple times but just thought it was contributed to the hard braking. it might be linked to the integrated tail light i installed. Where does the resistor get wired? I'm assuming in parallel with the brake portion of the tail light? What size resistor?
 
A common issue with the aftermarket integrated tail lights is that they cause intermittent ABS faults. The fix is to wire a resistor in the circuit. I've done it both of my Gen 2's.

Not sure I have any documentation on the fix, I'd have to look when I get a chance. It's another one of those things that was "lost" when the other forum went down.
It's 2021 and mine has just started doing the same thing. Has anyone dug up a fix since this thread was started 2 years ago? I had an integrated tail light/indicator installed a month ago so it seems to be related. Here in the UK it is not legal to have the indicators integrated so I have separate units. They are LEDs and so have the resistors wired in, but it means that the integrated tail light doesn't have resistors. Maybe that is the problem.
 
Does anyone have a fix for this? I just installed the amazon integrated taillight and have this flickering ABS light. I found a 18 ohm resistor wired in on the old taillight on the yellow brake light wire and added it to the new taillight but the issue persists, I think the value of the resistor is wrong. The ABS fault code is 24 which is brake light signal not always received while braking.
 
Does anyone have a fix for this? I just installed the amazon integrated taillight and have this flickering ABS light. I found a 18 ohm resistor wired in on the old taillight on the yellow brake light wire and added it to the new taillight but the issue persists, I think the value of the resistor is wrong. The ABS fault code is 24 which is brake light signal not always received while braking.
Do you have a link for the light you bought? I would like to look at it. I am working on a lighting project and want to dot my i's and cross my t's.
 
Okay so my fix works, I wired in a small 20A 12V relay on the yellow brake light wire (from brake light switches to pin 85 on relay) earth pin 86, take a battery live from the thick red wire on the voltage regulator (pin 30 on relay) connect the yellow wire to the brake light (pin 87 on relay). Everything functions as it should and the flickers can no longer feed electronic noise to the ABS ECU. Everything is done in the tailpiece behind the rear brake fluid reservoir.
 

Latest posts

Back
Top